Install Odoo 9 on Ubuntu 14.04 LTS

See AMP Version

Install Odoo 9 on Ubuntu 14.04 LTS

Install Odoo 9 on Ubuntu

Install Odoo 9 on Ubuntu

You might have tried and failed to install Odoo 9 on Ubuntu server. The installation fails because python-ofxparse is missing in the package installer. This is why you face this error message:

The following packages have unmet dependencies:
odoo: Depends: python-ofxparse but it is not installable
Recommends: antiwrd but it is not going to be installed
Recommends: PostgreSQL but it is not going to be installed
Recommends: python-gevent but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The solution is adding necessary repository to your /etc/apt/sources.list file and installing the python-ofxparse package manually.

Here is all the steps you need to follow in order to install Odoo 9 on Ubuntu 14.04LTS server:

 

We also prepared a short video instruction for installing Odoo 9 on Ubuntu

Enjoy Odooing

Do not hesitate to contact me via [email protected] if you need help.

4 Comments

Karan

Thanks for the instructions. I was able to install on the DigitalOcean server. I was getting an deb error which I fixed by editing the sources.list file and removed the ” from the last 2 sources I added.

Reply
hamid

Thanks Karan for sharing with us. If you edit your sources.list file directly, you don’t need the ” sign. The echo command adds the line of source without “

Reply

Leave a Reply

Your email address will not be published. Required fields are marked *